Hosting Performance Degradation | s2927.can1.stableserver.net
Resolved
Mar 17, 2026 10:52 UTC
Incident Updates
-
Resolved 5 months ago · Mar 17, 2026 15:06 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved 5 months ago · Mar 17, 2026 10:52 UTC
We are experiencing some intermittent disruption to internet traffic on the server s2927.can1.stableserver.net Due to this, customers who have hosting and website services might be experiencing intermittent issues. Our infrastructure team are investigating and monitoring.